# Generated by go2rpm 1.8.0
%bcond_without check
%global debug_package %{nil}

# https://github.com/mozilla-services/pkcs7
%global goipath         go.mozilla.org/pkcs7
%global forgeurl        https://github.com/mozilla-services/pkcs7
%global commit          33d05740a3526e382af6395d3513e73d4e66d1cb

%gometa

%global godevelheader %{expand:
Requires:               openssl}

%global common_description %{expand:
Implements a subset of PKCS#7/Cryptographic Message Syntax (rfc2315, rfc5652).}

%global golicenses      LICENSE
%global godocs          README.md

Name:           %{goname}
Version:        0
Release:        0.6%{?dist}
Summary:        Implements a subset of PKCS#7/Cryptographic Message Syntax (rfc2315, rfc5652)

License:        MIT
URL:            %{gourl}
Source:         %{gosource}

BuildRequires:  openssl

%description %{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires

%install
%gopkginstall

%if %{with check}
%check
# Skip DSA and SHA1 tests as they're deprecated and fail with new Go releases
for test in "TestDSASignWithOpenSSLAndVerify"\
; do
awk -i inplace '/^func.*'"$test"'\(/ { print; print "\tt.Skip(\"disabled failing test\")"; next}1' $(grep -rl $test)
done
sed -e '/\t\tx509.SHA1WithRSA,/d' -i sign_test.go
sed -e '/\t\tx509.SHA1WithRSA,/d' -i verify_test.go
sed -e '/\t\tx509.ECDSAWithSHA1,/d' -i sign_test.go
sed -e '/\t\tx509.ECDSAWithSHA1,/d' -i verify_test.go
%gocheck
%endif

%gopkgfiles

%changelog
* Wed Aug 31 2022 Mikel Olasagasti Uranga <mikel@olasagasti.info> - 0-0.6
- Update to latest commit

* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0-0.5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0-0.4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0-0.3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0-0.2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Thu Oct 01 00:26:01 CEST 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0-0.1.20200930git432b235
- Initial package