## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1.6.0
%bcond_without check

# https://github.com/gopasspw/gopass-hibp
%global goipath         github.com/gopasspw/gopass-hibp
Version:                1.15.2

%gometa
%global goname gopass-hibp

%global common_description %{expand:
Gopass haveibeenpwnd.com integration.}

%global golicenses      LICENSE
%global godocs          README.md CHANGELOG.md

Name:           %{goname}
Release:        %autorelease
Summary:        Gopass haveibeenpwnd.com integration

License:        MIT
URL:            %{gourl}
Source0:        %{gosource}

%description
%{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires

%build
%gobuild -o %{gobuilddir}/bin/gopass-hibp %{goipath}

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck -d github.com/gopasspw/gopass-hibp/pkg/hibp/api
%endif

%files
%license LICENSE
%doc README.md CHANGELOG.md
%{_bindir}/*

%gopkgfiles

%changelog
* Tue Dec 20 2022 Fabio Alessandro Locati <me@fale.io> 1.15.2-1
- Update to 1.5.2. Fixes rhbz#2155103

* Mon Dec 12 2022 Fabio Alessandro Locati <me@fale.io> 1.15.0-2
- re-enable tests

* Sat Dec 10 2022 Fabio Alessandro Locati <me@fale.io> 1.15.0-1
- update to 1.15.0. fixes rhbz#2123983

* Mon Aug 15 2022 Fabio Alessandro Locati <me@fale.io> 1.14.3-1
- updateto 1.14.3

* Wed Aug 10 2022 Maxwell G <gotmax@e.email> 1.12.0-5
- Rebuild to fix FTBFS

* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 1.12.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Tue Jul 19 2022 Maxwell G <gotmax@e.email> 1.12.0-3
- Rebuild for
  CVE-2022-{1705,32148,30631,30633,28131,30635,30632,30630,1962} in golang

* Sat Jun 18 2022 Robert-André Mauchin <zebob.m@gmail.com> 1.12.0-2
- Rebuilt for CVE-2022-1996, CVE-2022-24675, CVE-2022-28327,
  CVE-2022-27191, CVE-2022-29526, CVE-2022-30629

* Wed May 11 2022 Fabio Alessandro Locati <me@fale.io> 1.12.0-1
- initial version. closes rhbz#2082975