## START: Set by rpmautospec
## (rpmautospec version 0.2.5)
%define autorelease(e:s:pb:) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{?dist}
## END: Set by rpmautospec

# Generated by go2rpm 1.5.0
%bcond_without check

# https://github.com/open-telemetry/opentelemetry-proto-go
%global goipath         go.opentelemetry.io/proto
%global forgeurl        https://github.com/open-telemetry/opentelemetry-proto-go
Version:                0.11.0

%gometa

%global common_description %{expand:
Protobuf definitions for the OpenTelemetry protocol (OTLP).}

%global golicenses      LICENSE
%global godocs          CONTRIBUTING.md RELEASING.md CHANGELOG.md README.md

Name:           %{goname}
Release:        %autorelease
Summary:        Protobuf definitions for the OpenTelemetry protocol (OTLP)

# Upstream license specification: Apache-2.0
License:        ASL 2.0
URL:            %{gourl}
Source0:        %{gosource}
Source1:        https://github.com/open-telemetry/opentelemetry-proto/archive/v%{version}/opentelemetry-proto-%{version}.tar.gz

BuildRequires:  golang(github.com/golang/protobuf/descriptor)
BuildRequires:  golang(github.com/golang/protobuf/proto)
BuildRequires:  golang(github.com/grpc-ecosystem/grpc-gateway/runtime)
BuildRequires:  golang(github.com/grpc-ecosystem/grpc-gateway/utilities)
BuildRequires:  golang(google.golang.org/grpc)
BuildRequires:  golang(google.golang.org/grpc/codes)
BuildRequires:  golang(google.golang.org/grpc/grpclog)
BuildRequires:  golang(google.golang.org/grpc/metadata)
BuildRequires:  golang(google.golang.org/grpc/status)
BuildRequires:  golang(google.golang.org/protobuf/reflect/protoreflect)
BuildRequires:  golang(google.golang.org/protobuf/runtime/protoimpl)

%description
%{common_description}

%gopkg

%prep
%goprep
tar xvf %{S:1} --strip 1

%install
%gopkginstall

%if %{with check}
%check
%gocheck
%endif

%gopkgfiles

%changelog
* Sat Jan 29 2022 Maxwell G <gotmax@e.email> 0.11.0-1
- Update to 0.11.0.

* Mon Aug 02 2021 Robert-André Mauchin <zebob.m@gmail.com> 0.9.0-2
- Uncommitted changes

* Mon Aug 02 2021 Robert-André Mauchin <zebob.m@gmail.com> 0.9.0-1
- Initial release