## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1
%bcond_without check

# https://github.com/bugst/go-serial
%global goipath         go.bug.st/serial
%global forgeurl        https://github.com/bugst/go-serial
Version:                1.5.0

%gometa

%global common_description %{expand:
A cross-platform serial library for Golang.}

%global golicenses      LICENSE
%global godocs          README.md

Name:           %{goname}-1
Release:        %autorelease
Summary:        Cross-platform serial library for Golang

# Upstream license specification: BSD-3-Clause
License:        BSD
URL:            %{gourl}
Source0:        %{gosource}

BuildRequires:  golang(github.com/creack/goselect)
BuildRequires:  golang(github.com/stretchr/testify/require)
BuildRequires:  golang(golang.org/x/sys/unix)
BuildRequires:  socat

%description
%{common_description}

%gopkg

%prep
%goprep

%build
for cmd in portlist; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license LICENSE
%doc README.md
%{_bindir}/*

%gopkgfiles

%changelog
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> 1.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Sun Jan 08 2023 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.5.0-1
- Update to latest version (#2158890)

* Sun Dec 04 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.4.1-1
- Update to latest version (#2149721)

* Sun Oct 02 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.4.0-1
- Update to latest version (#2124238)

* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 1.3.5-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Tue Jul 19 2022 Maxwell G <gotmax@e.email> 1.3.5-4
- Rebuild for
  CVE-2022-{1705,32148,30631,30633,28131,30635,30632,30630,1962} in golang

* Sat Jun 18 2022 Robert-André Mauchin <zebob.m@gmail.com> 1.3.5-3
- Rebuilt for CVE-2022-1996, CVE-2022-24675, CVE-2022-28327,
  CVE-2022-27191, CVE-2022-29526, CVE-2022-30629

* Fri Jun 17 2022 Robert-André Mauchin <zebob.m@gmail.com> 1.3.5-2
- Rebuilt for CVE-2022-1996, CVE-2022-24675, CVE-2022-28327,
  CVE-2022-27191, CVE-2022-29526, CVE-2022-30629

* Tue Mar 01 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.3.5-1
- Update to latest version (#2056924)

* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> 1.3.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Sat Jan 08 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.3.4-1
- Update to latest version (#2037316)

* Sat Sep 18 2021 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.3.3-1
- Update to latest version (#2003992)

* Sun Sep 05 2021 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.3.2-1
- Update to latest version (#2000316)

* Sun Jul 25 2021 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.3.1-1
- Update to latest version (#1978030)

* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Sun Jul 11 2021 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.3.0-1
- Update to latest version (#1978030)

* Sat Feb 27 2021 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.1.3-1
- Update to latest version (#1933394)

* Tue Feb 16 2021 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.1.2-1
- Update to latest version (#1929011)

* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Tue Sep 22 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.1.1-1
- Update to latest version (#1881240)

* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Sun Apr 19 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.1.0-1
- Update to latest version

* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Wed Jan 01 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.0.0-1
- Update to latest version

* Fri Oct 18 06:39:03 EDT 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 0-0.1.20191018git5f7892a
- Initial package