%define pypi_name requests-glob
%define python_name python3-%{pypi_name}
Name:           python-%{pypi_name}
Version:        0.1
Release:        %autorelease
# Fill in the actual package summary to submit package to Fedora
Summary:        File transport adapter for Requests

# Check if the automatically generated License and its spelling is correct for Fedora
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
License:        Apache-2.0
URL:            https://github.com/dashea/requests-file
Source:         requests_glob-%{version}.tar.gz

BuildRequires:  pyproject-rpm-macros
BuildRequires:  python3-devel
BuildRequires:  fdupes
BuildArch:      noarch

# Fill in the actual package description to submit package to Fedora
%global _description %{expand:
Requests-Glob
=============

Requests-Glob is a transport adapter for use with the `Requests`_ Python
library to allow local filesystem access via glob:\/\/ URLs.

To use:

.. code-block:: python

    import requests
    from requests_glob import GlobAdapter

    s = requests.Session()
    s.mount('glob://', GlobAdapter())

    resp = s.get('glob:///glob_expression')

Features
--------

- Will open and read local files
- Might set a Content-Length header
- That's about it

Also, url can contain query information, such as glob (yes - default, no),
glob_include_hidden (no - default, yes), glob_recursive (yes - default, no)

No encoding information is set in the response object, so be careful using
Response.text: the chardet library will be used to convert the file to a
unicode type and it may not detect what you actually want.

EACCES is converted to a 403 status code, and ENOENT is converted to a
404. All other IOError types are converted to a 400.

Contributing
------------

Contributions welcome! Feel free to open a pull request against
https://github.com/huakim/python-requests-glob

License
-------

To maximise compatibility with Requests, this code is licensed under the Apache
license. See LICENSE for more details.

.. _`Requests`: https://github.com/kennethreitz/requests
}

%description %_description

%package -n %{python_name}
Summary:        %{summary}

%description -n %{python_name} %_description

%prep
%autosetup -p1 -n %{lua: print(rpm.expand('%{pypi_name}'):gsub('-','_')..rpm.expand('-%{version}')) }


%generate_buildrequires
# Keep only those extras which you actually want to package or use during tests
%pyproject_buildrequires 


%build
%pyproject_wheel


%install
%pyproject_install
# For official Fedora packages, including files with '*' +auto is not allowed
# Replace it with a list of relevant Python modules/globs and list extra files in %%files
%pyproject_save_files '*' +auto
%if %{with test}
%check
%pyproject_check_import
%pytest
%endif

%files -n %{python_name} -f %{pyproject_files}

%changelog
%autochangelog