## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}

%global crate libc

Name:           rust-libc
Version:        0.2.139
Release:        %autorelease
Summary:        Raw FFI bindings to platform libraries like libc

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/libc
Source:         %{crates_source}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Raw FFI bindings to platform libraries like libc.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       glibc-devel

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+align-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+align-devel %{_description}

This package contains library source intended for building other packages which
use the "align" feature of the "%{crate}" crate.

%files       -n %{name}+align-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+const-extern-fn-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+const-extern-fn-devel %{_description}

This package contains library source intended for building other packages which
use the "const-extern-fn" feature of the "%{crate}" crate.

%files       -n %{name}+const-extern-fn-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+extra_traits-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+extra_traits-devel %{_description}

This package contains library source intended for building other packages which
use the "extra_traits" feature of the "%{crate}" crate.

%files       -n %{name}+extra_traits-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+use_std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+use_std-devel %{_description}

This package contains library source intended for building other packages which
use the "use_std" feature of the "%{crate}" crate.

%files       -n %{name}+use_std-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires
echo 'glibc-devel'

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Fri Dec 23 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.139-1
- Update to version 0.2.139; Fixes RHBZ#2155777

* Sun Dec 04 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.138-1
- Update to version 0.2.138; Fixes RHBZ#2150452

* Fri Nov 11 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.137-1
- Update to version 0.2.137; Fixes RHBZ#2133434

* Wed Oct 05 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.134-1
- Update to version 0.2.134; Fixes RHBZ#2127967

* Fri Sep 02 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.132-1
- Update to version 0.2.132; Fixes RHBZ#2118767

* Tue Aug 16 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.131-1
- Update to version 0.2.131; Fixes RHBZ#2117061

* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.127-1
- Update to version 0.2.127; Fixes RHBZ#2115139

* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.2.126-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Mon May 23 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.126-1
- Update to version 0.2.126; Fixes RHBZ#2087028

* Thu May 12 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.125-1
- Update to version 0.2.125; Fixes RHBZ#2072786

* Tue Mar 29 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.121-1
- Update to version 0.2.121; Fixes RHBZ#2065853

* Thu Mar 17 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.120-1
- Update to version 0.2.120; Fixes RHBZ#2063878

* Sun Feb 20 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.119-1
- Update to version 0.2.119; Fixes RHBZ#2054644

* Wed Feb 09 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.117-1
- Update to version 0.2.117; Fixes RHBZ#2049899

* Mon Jan 31 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.116-1
- Update to version 0.2.116; Fixes RHBZ#2047233

* Wed Jan 26 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.114-1
- Update to version 0.2.114; Fixes RHBZ#2044977

* Fri Jan 21 2022 Fabio Valentini <decathorpe@gmail.com> 0.2.113-1
- Update to version 0.2.113; Fixes RHBZ#2043001

* Tue Dec 21 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.112-1
- Update to version 0.2.112; Fixes RHBZ#2030918

* Thu Dec 09 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.109-1
- Update to version 0.2.109; Fixes RHBZ#2029070

* Tue Nov 23 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.108-1
- Update to version 0.2.108; Fixes RHBZ#2025190

* Wed Nov 10 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.107-1
- Update to version 0.2.107; Fixes RHBZ#2020897

* Mon Nov 01 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.106-1
- Update to version 0.2.106; Fixes RHBZ#2014737

* Mon Sep 27 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.103-1
- Update to version 0.2.103; Fixes RHBZ#2004460

* Sun Aug 29 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.101-1
- Update to version 0.2.101; Fixes RHBZ#1997825

* Sat Aug 21 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.100-1
- Update to version 0.2.100; Fixes RHBZ#1996242

* Tue Aug 10 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.99-1
- Update to version 0.2.99; Fixes RHBZ#1991801

* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> 0.2.98-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Fri Jul 09 2021 Fabio Valentini <decathorpe@gmail.com> 0.2.98-1
- Update to version 0.2.98; Fixes RHBZ#1980022

* Fri Jun 18 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.97-1
- Update to version 0.2.97.
- Fixes RHBZ#1969709

* Thu May 27 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.95-1
- Update to version 0.2.95.
- Fixes RHBZ#1964667

* Tue Apr 27 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.94-1
- Update to version 0.2.94.
- Fixes RHBZ#1953638

* Tue Apr 06 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.93-1
- Update to version 0.2.93.
- Fixes RHBZ#1946703

* Wed Mar 31 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.92-1
- Update to version 0.2.92.
- Fixes RHBZ#1944644

* Fri Mar 26 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.91-1
- Update to version 0.2.91.
- Fixes RHBZ#1941900

* Sun Mar 21 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.90-1
- Update to version 0.2.90.
- Fixes RHBZ#1935896

* Wed Mar 03 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.87-1
- Update to version 0.2.87.
- Fixes RHBZ#1934050

* Mon Feb 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.86-1
- Update to version 0.2.86.
- Fixes RHBZ#1921415

* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.82-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Sat Jan 09 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.82-1
- Update to version 0.2.82.
- Fixes RHBZ#1913959

* Mon Dec 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.2.81-1
- Update to version 0.2.81.
- Fixes RHBZ#1904841

* Wed Nov 11 2020 Fabio Valentini <decathorpe@gmail.com> - 0.2.80-2
- Reintroduce accidentally removed "align" feature.

* Wed Nov 04 2020 Fabio Valentini <decathorpe@gmail.com> - 0.2.80-1
- Update to version 0.2.80.
- Remove nightly-only and compiler-internal features and dependencies
- Fixes RHBZ#1891346

* Mon Oct 05 2020 Fabio Valentini <decathorpe@gmail.com> - 0.2.79-1
- Update to version 0.2.79.

* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.2.78-1
- Update to version 0.2.78.

* Fri Sep 11 2020 Josh Stone <jistone@redhat.com> - 0.2.77-1
- Update to 0.2.77

* Thu Aug 20 2020 Josh Stone <jistone@redhat.com> - 0.2.76-1
- Update to 0.2.76

* Tue Jul 28 2020 Josh Stone <jistone@redhat.com> - 0.2.74-1
- Update to 0.2.74

* Wed Jul 22 2020 Josh Stone <jistone@redhat.com> - 0.2.73-1
- Update to 0.2.73

* Fri Jul 10 2020 Josh Stone <jistone@redhat.com> - 0.2.72-1
- Update to 0.2.72

* Tue May 26 2020 Josh Stone <jistone@redhat.com> - 0.2.71-1
- Update to 0.2.71

* Tue May 12 2020 Josh Stone <jistone@redhat.com> - 0.2.70-1
- Update to 0.2.70

* Tue Apr 14 2020 Josh Stone <jistone@redhat.com> - 0.2.69-1
- Update to 0.2.69

* Tue Mar 17 2020 Josh Stone <jistone@redhat.com> - 0.2.68-1
- Update to 0.2.68

* Tue Mar 17 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.2.67-2
- Add back missing subpackages

* Fri Feb 21 2020 Josh Stone <jistone@redhat.com> - 0.2.67-1
- Update to 0.2.67

* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.66-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Mon Dec 02 08:21:51 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.66-1
- Update to 0.2.66

* Fri Oct 25 19:18:53 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.65-1
- Update to 0.2.65

* Sun Aug 25 14:50:22 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.62-1
- Update to 0.2.62

* Sat Aug 03 15:45:53 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.60-1
- Update to 0.2.60

* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.59-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Sat Jul 13 11:19:04 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.59-1
- Update to 0.2.59

* Thu Jun 20 12:27:42 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.58-3
- Regenerate

* Sun Jun 09 11:39:04 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.58-2
- Regenerate

* Mon Jun 03 2019 Josh Stone <jistone@redhat.com> - 0.2.58-1
- Update to 0.2.58

* Sat Jun 01 2019 Josh Stone <jistone@redhat.com> - 0.2.57-1
- Update to 0.2.57

* Thu May 02 2019 Josh Stone <jistone@redhat.com> - 0.2.54-1
- Update to 0.2.54

* Fri Mar 29 17:59:24 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.51-1
- Update to 0.2.51

* Tue Mar 05 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.50-1
- Update to 0.2.50

* Fri Feb 22 2019 Josh Stone <jistone@redhat.com> - 0.2.49-1
- Update to 0.2.49

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.48-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Wed Jan 23 2019 Josh Stone <jistone@redhat.com> - 0.2.48-1
- Update to 0.2.48

* Mon Jan 14 2019 Josh Stone <jistone@redhat.com> - 0.2.47-1
- Update to 0.2.47

* Tue Jan 08 2019 Josh Stone <jistone@redhat.com> - 0.2.46-1
- Update to 0.2.46

* Mon Dec 10 2018 Josh Stone <jistone@redhat.com> - 0.2.45-1
- Update to 0.2.45

* Mon Nov 26 2018 Josh Stone <jistone@redhat.com> - 0.2.44-1
- Update to 0.2.44

* Fri Oct 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.43-3
- Adapt to new packaging

* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.43-2
- Run tests in infrastructure

* Tue Aug 07 2018 Josh Stone <jistone@redhat.com> - 0.2.43-1
- Update to 0.2.43

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.42-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Tue Jun 05 2018 Josh Stone <jistone@redhat.com> - 0.2.42-1
- Update to 0.2.42

* Fri May 25 2018 Josh Stone <jistone@redhat.com> - 0.2.41-1
- Update to 0.2.41

* Mon Mar 26 2018 Josh Stone <jistone@redhat.com> - 0.2.40-1
- Update to 0.2.40

* Tue Mar 06 2018 Josh Stone <jistone@redhat.com> - 0.2.39-1
- Update to 0.2.39

* Tue Feb 27 2018 Josh Stone <jistone@redhat.com> - 0.2.37-1
- Update to 0.2.37

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.36-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Sat Jan 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.36-1
- Update to 0.2.36

* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.35-2
- Rebuild for rust-packaging v5

* Thu Jan 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.35-1
- Update to 0.2.35

* Thu Nov 30 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.34-1
- Update to 0.2.34

* Mon Nov 20 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.33-2
- Add BuildRequires/Requires for glibc-devel

* Wed Nov 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.33-1
- Update to 0.2.33

* Fri Oct 27 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.32-1
- Update to 0.2.32

* Fri Jul 21 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.26-1
- Update to 0.2.26

* Fri Jul 07 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.25-1
- Update to 0.2.25

* Sun Jun 25 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.24-1
- Update to 0.2.24

* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.23-1
- Update to 0.2.23

* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.21-2
- Port to use rust-packaging

* Sun Mar 05 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.21-1
- Update to 0.2.21

* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.20-3
- Strip unneeded files

* Sun Feb 12 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.20-2
- Add license files
- Fix license tag

* Sun Feb 12 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.20-1
- Initial package