# generated by cabal-rpm-2.0.9
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name graphviz
%global pkgver %{pkg_name}-%{version}
# testsuite missing deps: fgl-arbitrary
Name: ghc-%{pkg_name}
Version: 2999.20.1.0
Release: 34%{?dist}
Summary: Bindings to Graphviz for graph visualization
License: BSD
Url: https://hackage.haskell.org/package/%{pkg_name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-base-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-colour-prof
BuildRequires: ghc-containers-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-dlist-prof
BuildRequires: ghc-fgl-prof
BuildRequires: ghc-filepath-prof
BuildRequires: ghc-mtl-prof
BuildRequires: ghc-polyparse-prof
BuildRequires: ghc-process-prof
BuildRequires: ghc-temporary-prof
BuildRequires: ghc-text-prof
BuildRequires: ghc-wl-pprint-text-prof
# End cabal-rpm deps
%description
This library provides bindings for the Dot language used by the Graphviz
() suite of programs for visualizing graphs, as well as
functions to call those programs.
Main features of the graphviz library include:
* Almost complete coverage of all Graphviz attributes and syntax.
* Support for specifying clusters.
* The ability to use a custom node type.
* Functions for running a Graphviz layout tool with all specified output types.
* The ability to not only generate but also parse Dot code with two options:
strict and liberal (in terms of ordering of statements).
* Functions to convert FGL graphs and other graph-like data structures to Dot
code - including support to group them into clusters - with a high degree of
customization by specifying which attributes to use and limited support for the
inverse operation.
* Round-trip support for passing an FGL graph through Graphviz to augment node
and edge labels with positional information, etc.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%if %{with ghc_prof}
%package prof
Summary: Haskell %{pkg_name} profiling library
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (%{name}-devel and ghc-prof)
%description prof
This package provides the Haskell %{pkg_name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q -n %{pkgver}
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
# End cabal-rpm install
%files -f %{name}.files
# Begin cabal-rpm files:
%license LICENSE.md
# End cabal-rpm files
%files devel -f %{name}-devel.files
%doc Changelog.md README.md TODO.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%license LICENSE.md
%endif
%if %{with ghc_prof}
%files prof -f %{name}-prof.files
%endif
%changelog
* Thu Jul 21 2022 Fedora Release Engineering - 2999.20.1.0-34
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jun 17 2022 Jens Petersen - 2999.20.1.0-33
- rebuild
* Thu Jan 20 2022 Fedora Release Engineering - 2999.20.1.0-32
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Aug 06 2021 Jens Petersen - 2999.20.1.0-31
- rebuild
* Thu Jul 22 2021 Fedora Release Engineering - 2999.20.1.0-30
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Mon May 31 2021 Jens Petersen - 2999.20.1.0-29
- bump over darcs
* Mon May 24 2021 Jens Petersen - 2999.20.1.0-1
- spec file generated by cabal-rpm-2.0.9