## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 26
# * Tests require the previous version of rstest.
%bcond_with check
%global debug_package %{nil}

%global crate rstest

Name:           rust-rstest
Version:        0.23.0
Release:        %autorelease
Summary:        Rust fixture based test framework

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/rstest
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Rust fixture based test framework. It use procedural macro to implement
fixtures and table based tests.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+async-timeout-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+async-timeout-devel %{_description}

This package contains library source intended for building other packages which
use the "async-timeout" feature of the "%{crate}" crate.

%files       -n %{name}+async-timeout-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+crate-name-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+crate-name-devel %{_description}

This package contains library source intended for building other packages which
use the "crate-name" feature of the "%{crate}" crate.

%files       -n %{name}+crate-name-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Mon Nov 11 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.23.0-1
- Update to 0.23.0 (close RHBZ#2274161)

* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Mon Sep 25 2023 Fabio Valentini <decathorpe@gmail.com> - 0.18.2-1
- Update to version 0.18.2; Fixes RHBZ#2219708

* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Sun May 21 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.17.0-1
- Initial Fedora package
## END: Generated by rpmautospec