## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 24
# cyclic dependency on zerocopy
# pinned to the trybuild 1.0.80
%bcond_with check
%global debug_package %{nil}

%global crate zerocopy-derive

Name:           rust-zerocopy-derive
Version:        0.6.3
Release:        %autorelease
Summary:        Custom derive for traits from the zerocopy crate

License:        BSD-2-Clause
URL:            https://crates.io/crates/zerocopy-derive
Source:         %{crates_source}
Patch:          trybuild.patch

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Custom derive for traits from the zerocopy crate.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Wed Aug 16 2023 John Doe <packager@example.com> - 0.6.3-1
- Uncommitted changes