# Created by pyp2rpm-3.3.7
%global pypi_name django-app-settings
%global pypi_version 0.7.1

Name:           python-%{pypi_name}
Version:        %{pypi_version}
Release:        1%{?dist}
Summary:        Application settings helper for Django apps

License:        ISC
URL:            https://github.com/pawamoy/django-appsettings
Source0:        %{pypi_source}
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3dist(django)
BuildRequires:  python3dist(setuptools)
BuildRequires:  python3dist(sphinx)
#BuildRequires:  python3dist(pytest)
BuildRequires:  python3-sphinx_rtd_theme

%description
 Django AppSettings Application settings helper for Django apps.Why another
*app settings* app? Because none of the other suited my needs!This one is
simple to use, and works with unit tests overriding settings.Installation ::
pip install django-app-settingsDocumentation On ReadTheDocs_.. _On ReadTheDocs:
To run all the tests: tox. See CONTRIBUTING_... _CONTRIBUTING: usage .. code::
python

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}

Requires:       python3dist(django)
%description -n python3-%{pypi_name}
 Django AppSettings Application settings helper for Django apps.Why another
*app settings* app? Because none of the other suited my needs!This one is
simple to use, and works with unit tests overriding settings.Installation ::
pip install django-app-settingsDocumentation On ReadTheDocs_.. _On ReadTheDocs:
To run all the tests: tox. See CONTRIBUTING_... _CONTRIBUTING: usage .. code::
python

%package -n python-%{pypi_name}-doc
Summary:        django-app-settings documentation
%description -n python-%{pypi_name}-doc
Documentation for django-app-settings

%prep
%autosetup -n %{pypi_name}-%{pypi_version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build
# generate html docs
PYTHONPATH=${PWD} sphinx-build-3 docs html
# remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}

%install
%py3_install

%files -n python3-%{pypi_name}
%license LICENSE
%doc README.rst docs/readme.rst
%{python3_sitelib}/appsettings
%{python3_sitelib}/django_app_settings-%{pypi_version}-py%{python3_version}.egg-info

%files -n python-%{pypi_name}-doc
%doc html
%license LICENSE

%changelog
* Thu Oct 21 2021 Jaromir Talir <jaromir.talir@nic.cz> - 0.7.1-1
- Initial package.