## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 3;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1.14.0
%bcond check 1
%bcond bootstrap 0

%if %{with bootstrap}
%global debug_package %{nil}
%endif

%if %{with bootstrap}
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^golang\\(.*\\)$
%endif

# https://github.com/nwg-piotr/nwg-bar
%global goipath         github.com/nwg-piotr/nwg-bar
Version:                0.1.6

%gometa -L -f

%global common_description %{expand:
GTK3-based button bar for wlroots-based compositors.}

%global golicenses      LICENSE
%global godocs          README.md

Name:           nwg-bar
Release:        %autorelease
Summary:        GTK3-based button bar for wlroots-based compositors

License:        MIT
URL:            %{gourl}
Source:         %{gosource}

%description %{common_description}

%gopkg

%prep
%goprep -A
%autopatch -p1

%if %{without bootstrap}
%generate_buildrequires
%go_generate_buildrequires
%endif

%if %{without bootstrap}
%build
%gobuild -o %{gobuilddir}/bin/nwg-bar %{goipath}
%endif

%install
%gopkginstall
%if %{without bootstrap}
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/
install -m 0755 -vd                     %{buildroot}%{_datadir}/%{name}/images
install -m 0644 -vp images/*            %{buildroot}%{_datadir}/%{name}/images/
install -m 0644 -vp config/*            %{buildroot}%{_datadir}/%{name}/
%endif

%if %{without bootstrap}
%if %{with check}
%check
%gocheck
%endif
%endif

%if %{without bootstrap}
%files
%license LICENSE
%doc README.md
%{_bindir}/nwg-bar
%{_datadir}/nwg-bar/
%endif

%gopkgfiles

%changelog
## START: Generated by rpmautospec
* Wed Aug 28 2024 Neal Gompa <ngompa@fedoraproject.org> - 0.1.6-3
- Install nwg-bar config

* Wed Aug 28 2024 Neal Gompa <ngompa@fedoraproject.org> - 0.1.6-2
- Install nwg-bar images

* Tue Aug 27 2024 Neal Gompa <ngompa@fedoraproject.org> - 0.1.6-1
- Initial package for Fedora (rhbz#2308060)
## END: Generated by rpmautospec