Name:           superfile
Version:        1.1.5
Release:        %autorelease
Summary:        Pretty fancy and modern terminal file manager

License: MIT
URL: https://superfile.netlify.app/
Source0: https://github.com/yorukot/superfile/archive/refs/heads/main.zip

BuildRequires: golang
BuildRequires: git

%description
Pretty fancy and modern terminal file manager

%prep
# %setup -T -q -n %{name} -c -a 0
cd %{_builddir}
rm -rf %{name}
mkdir -p %{name}
echo "A" | /usr/lib/rpm/rpmuncompress -x %{SOURCE0}

%global _missing_build_ids_terminate_build 0
%define debug_package %{nil}

%build
echo `ls`
cd %{name}-main
CGO_ENABLED=1 go build -o ./bin/spf -ldflags=-linkmode=external
%install
mkdir -p %{buildroot}/usr/bin
echo `ls`
cd %{name}-main
cp ./bin/spf %{buildroot}/usr/bin

%files
/usr/bin/spf

%changelog
%autochangelog