## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

Name:           python3-flake8-docstrings
Version:        1.7.0
Release:        %autorelease
Summary:        Extension for flake8 which uses pydocstyle to check docstrings

License:        MIT
URL:            https://github.com/pycqa/flake8-docstrings
Source:         %{pypi_source flake8_docstrings}

BuildArch:      noarch
BuildRequires:  python3-devel
BuildRequires:  python3-wheel
BuildRequires:  python3-packaging
BuildRequires:  python3-pip >= 19
BuildRequires:  python3-setuptools >= 40.8
BuildRequires:  python3-flake8 >= 3
BuildRequires:  python3-pydocstyle >= 2.1

%global _description %{expand:
Extension for flake8 which uses pydocstyle to check docstrings.}

%description %_description

Summary:        %{summary}

%prep
%autosetup -p1 -n flake8_docstrings-%{version}

%generate_buildrequires
%pyproject_buildrequires

%build
%pyproject_wheel

%install
%pyproject_install
%pyproject_save_files -l flake8_docstrings

%check
%pyproject_check_import

%files -n python3-flake8-docstrings -f %{pyproject_files}


%changelog
## START: Generated by rpmautospec
* Mon Jan 20 2025 saypaul <saypaul@redhat.com> - 1.7.0-2
- compatibility with copr

* Mon Jan 20 2025 saypaul <saypaul@redhat.com> - 1.7.0-1
- Inital commit
## END: Generated by rpmautospec