## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 3;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

%global debug_package %{nil}

Name:           python-dbus-fast
Version:        2.39.3
Release:        %autorelease
Summary:        A faster version of dbus-next

License:        MIT
URL:            https://pypi.org/project/dbus-fast/
Source:         %{pypi_source dbus_fast}

BuildRequires:  python3-devel


%global _description %{expand:
A faster version of dbus-next originally from the great DBus next library}


%description %_description

%package -n     python3-dbus-fast
Summary:        %{summary}

%description -n python3-dbus-fast %_description


%prep
%autosetup -p1 -n dbus_fast-%{version}


%generate_buildrequires
%pyproject_buildrequires

# Lower minimum versions
sed -i 's/65.4.1/53.0.0/g' pyproject.toml
sed -i 's/Cython>=3,/Cython/g' pyproject.toml
sed -i 's/Cython = ">=3,/Cython = "/g' pyproject.toml

%build
%pyproject_wheel


%install
%pyproject_install
%pyproject_save_files -L dbus_fast


%check
%pyproject_check_import


%files -n python3-dbus-fast -f %{pyproject_files}
%license LICENSE
%doc README.md


%changelog
## START: Generated by rpmautospec
* Sat Mar 08 2025 Luca Magrone <luca@magrone.cc> - 2.39.3-1
- Initial package

## END: Generated by rpmautospec