# Generated by rust2rpm 24
%bcond_without check

%global crate sarif-fmt

Name:           rust-sarif-fmt
Version:        0.4.1
Release:        %autorelease
Summary:        View (pretty print) SARIF files in terminal

License:        MIT
URL:            https://crates.io/crates/sarif-fmt
Source:         %{crates_source}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
View (pretty print) SARIF files in terminal.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# Apache-2.0
# Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# MIT
# Unlicense OR MIT
License:        Apache-2.0 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND MIT AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown
# based on example from rpms/rust-git-delta

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc README.md
%{_bindir}/sarif-fmt

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build
%cargo_license_summary
%{cargo_license} > LICENSE.dependencies

%install
%cargo_install

%if %{with check}
%check
# !FIXME: tests are failing since they require specific setup - monorepo with rest of sarif crates (shellcheck-sarif, clang-tidy-sarif, etc.)
# see: https://github.com/psastras/sarif-rs/blob/fec0663197c2ed0dc7438a716df0e889aa5c119e/sarif-fmt/tests/shellcheck-test.rs#L32-L48
%cargo_test -- --no-run
%endif

%changelog
%autochangelog