## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

Name:           python-durationpy
Version:        0.9
Release:        %autorelease
Summary:        Module for converting between datetime.timedelta and Go's Duration strings

License:        MIT
URL:            https://github.com/icholy/durationpy
Source:         %{url}/archive/refs/tags/%{version}.tar.gz

BuildArch:      noarch
BuildRequires:  python3-devel
BuildRequires:  python3-pytest

%global _description %{expand:
Module for converting between datetime.timedelta and Go's Duration strings}

%description %_description

%package -n python3-durationpy
Summary:        %{summary}

%description -n python3-durationpy %_description

%prep
%autosetup -p1 -n durationpy-%{version}

%generate_buildrequires
%pyproject_buildrequires

%build
%pyproject_wheel

%install
%pyproject_install

%pyproject_save_files -l durationpy

%check
%pytest test.py

%files -n python3-durationpy -f %{pyproject_files}
%doc README.md
%license LICENSE

%changelog
## START: Generated by rpmautospec
* Wed Nov 06 2024 Miro Hrončok <miro@hroncok.cz> - 0.9-2
- Stop running tox for no reason

* Tue Nov 05 2024 Jason Montleon <jmontleo@redhat.com> - 0.9-1
- Initial Version
## END: Generated by rpmautospec