## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}

%global crate spdx

Name:           rust-spdx
Version:        0.10.8
Release:        %autorelease
Summary:        Helper crate for SPDX expressions

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/spdx
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Helper crate for SPDX expressions.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+text-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+text-devel %{_description}

This package contains library source intended for building other packages which
use the "text" feature of the "%{crate}" crate.

%files       -n %{name}+text-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Sun Jan 19 2025 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_42_Mass_Rebuild

* Fri Jan 03 2025 Fabio Valentini <decathorpe@gmail.com> - 0.10.8-1
- Update to version 0.10.8; Fixes RHBZ#2335030

* Thu Nov 28 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.7-1
- Update to version 0.10.7; Fixes RHBZ#2326446

* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Wed Jun 05 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.6-1
- Update to version 0.10.6; Fixes RHBZ#2284100

* Fri Mar 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.4-1
- Update to version 0.10.4; Fixes RHBZ#2266026

* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Wed Jan 10 2024 Fabio Valentini <decathorpe@gmail.com> - 0.10.3-1
- Update to version 0.10.3; Fixes RHBZ#2256745

* Wed Sep 13 2023 Fabio Valentini <decathorpe@gmail.com> - 0.10.2-1
- Initial import (#2237915)
## END: Generated by rpmautospec