# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}

%global crate serde-hjson

Name:           rust-serde-hjson
Version:        0.9.1
Release:        %autorelease
Summary:        Hjson serialization file format

License:        MIT
URL:            https://crates.io/crates/serde-hjson
Source:         %{crates_source}
# Removed README with non-existant path
Patch:          serde-hjson-fix-readme-path.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Hjson serialization file format.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
# FIXME: no license files detected
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+clippy-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+clippy-devel %{_description}

This package contains library source intended for building other packages which
use the "clippy" feature of the "%{crate}" crate.

%files       -n %{name}+clippy-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+linked-hash-map-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+linked-hash-map-devel %{_description}

This package contains library source intended for building other packages which
use the "linked-hash-map" feature of the "%{crate}" crate.

%files       -n %{name}+linked-hash-map-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+preserve_order-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+preserve_order-devel %{_description}

This package contains library source intended for building other packages which
use the "preserve_order" feature of the "%{crate}" crate.

%files       -n %{name}+preserve_order-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-testing-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-testing-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable-testing" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-testing-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog