# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate wiggle

Name:           rust-wiggle21
Version:        21.0.2
Release:        %autorelease
Summary:        Runtime components of wiggle code generator

License:        Apache-2.0 WITH LLVM-exception
URL:            https://crates.io/crates/wiggle
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

ExcludeArch:    ppc64le s390x

%global _description %{expand:
Runtime components of wiggle code generator.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tracing_log-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tracing_log-devel %{_description}

This package contains library source intended for building other packages which
use the "tracing_log" feature of the "%{crate}" crate.

%files       -n %{name}+tracing_log-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wasmtime-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wasmtime-devel %{_description}

This package contains library source intended for building other packages which
use the "wasmtime" feature of the "%{crate}" crate.

%files       -n %{name}+wasmtime-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wasmtime_async-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wasmtime_async-devel %{_description}

This package contains library source intended for building other packages which
use the "wasmtime_async" feature of the "%{crate}" crate.

%files       -n %{name}+wasmtime_async-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wiggle_metadata-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wiggle_metadata-devel %{_description}

This package contains library source intended for building other packages which
use the "wiggle_metadata" feature of the "%{crate}" crate.

%files       -n %{name}+wiggle_metadata-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+witx-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+witx-devel %{_description}

This package contains library source intended for building other packages which
use the "witx" feature of the "%{crate}" crate.

%files       -n %{name}+witx-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog