# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate wasm-encoder

Name:           rust-wasm-encoder
Version:        0.220.0
Release:        %autorelease
Summary:        Low-level WebAssembly encoder

License:        Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
URL:            https://crates.io/crates/wasm-encoder
Source:         %{crates_source}
# Make optional dependency mandatory
#Patch:          wasm-encoder-fix-missing-dep.diff
# Removed broken tests with wasmparser dependency
Patch:          wasm-encoder-fix-broken-tests.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A low-level WebAssembly encoder.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
# FIXME: no license files detected
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+component-model-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+component-model-devel %{_description}

This package contains library source intended for building other packages which
use the "component-model" feature of the "%{crate}" crate.

%files       -n %{name}+component-model-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wasmparser-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wasmparser-devel %{_description}

This package contains library source intended for building other packages which
use the "wasmparser" feature of the "%{crate}" crate.

%files       -n %{name}+wasmparser-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test -- --all-targets
%endif

%changelog
%autochangelog