# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate postcard

Name:           rust-postcard
Version:        1.0.10
Release:        %autorelease
Summary:        No_std + serde compatible message library for Rust

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/postcard
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A no_std + serde compatible message library for Rust.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
# FIXME: no license files detected
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+alloc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+alloc-devel %{_description}

This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.

%files       -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+crc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+crc-devel %{_description}

This package contains library source intended for building other packages which
use the "crc" feature of the "%{crate}" crate.

%files       -n %{name}+crc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+defmt-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+defmt-devel %{_description}

This package contains library source intended for building other packages which
use the "defmt" feature of the "%{crate}" crate.

%files       -n %{name}+defmt-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+embedded-io-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+embedded-io-devel %{_description}

This package contains library source intended for building other packages which
use the "embedded-io" feature of the "%{crate}" crate.

%files       -n %{name}+embedded-io-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+embedded-io-04-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+embedded-io-04-devel %{_description}

This package contains library source intended for building other packages which
use the "embedded-io-04" feature of the "%{crate}" crate.

%files       -n %{name}+embedded-io-04-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+embedded-io-06-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+embedded-io-06-devel %{_description}

This package contains library source intended for building other packages which
use the "embedded-io-06" feature of the "%{crate}" crate.

%files       -n %{name}+embedded-io-06-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+experimental-derive-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+experimental-derive-devel %{_description}

This package contains library source intended for building other packages which
use the "experimental-derive" feature of the "%{crate}" crate.

%files       -n %{name}+experimental-derive-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+heapless-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+heapless-devel %{_description}

This package contains library source intended for building other packages which
use the "heapless" feature of the "%{crate}" crate.

%files       -n %{name}+heapless-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+heapless-cas-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+heapless-cas-devel %{_description}

This package contains library source intended for building other packages which
use the "heapless-cas" feature of the "%{crate}" crate.

%files       -n %{name}+heapless-cas-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+paste-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+paste-devel %{_description}

This package contains library source intended for building other packages which
use the "paste" feature of the "%{crate}" crate.

%files       -n %{name}+paste-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+postcard-derive-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+postcard-derive-devel %{_description}

This package contains library source intended for building other packages which
use the "postcard-derive" feature of the "%{crate}" crate.

%files       -n %{name}+postcard-derive-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+use-crc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+use-crc-devel %{_description}

This package contains library source intended for building other packages which
use the "use-crc" feature of the "%{crate}" crate.

%files       -n %{name}+use-crc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+use-defmt-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+use-defmt-devel %{_description}

This package contains library source intended for building other packages which
use the "use-defmt" feature of the "%{crate}" crate.

%files       -n %{name}+use-defmt-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+use-std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+use-std-devel %{_description}

This package contains library source intended for building other packages which
use the "use-std" feature of the "%{crate}" crate.

%files       -n %{name}+use-std-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog