# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate derive_builder

Name:           rust-derive_builder0.9
Version:        0.9.0
Release:        %autorelease
Summary:        Rust macro to automatically implement the builder pattern for arbitrary structs

# Upstream license specification: MIT/Apache-2.0
License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/derive_builder
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Rust macro to automatically implement the builder pattern for arbitrary
structs.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+compiletest_rs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+compiletest_rs-devel %{_description}

This package contains library source intended for building other packages which
use the "compiletest_rs" feature of the "%{crate}" crate.

%files       -n %{name}+compiletest_rs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+env_logger-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+env_logger-devel %{_description}

This package contains library source intended for building other packages which
use the "env_logger" feature of the "%{crate}" crate.

%files       -n %{name}+env_logger-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+log-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+log-devel %{_description}

This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.

%files       -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+logging-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+logging-devel %{_description}

This package contains library source intended for building other packages which
use the "logging" feature of the "%{crate}" crate.

%files       -n %{name}+logging-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+nightlytests-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+nightlytests-devel %{_description}

This package contains library source intended for building other packages which
use the "nightlytests" feature of the "%{crate}" crate.

%files       -n %{name}+nightlytests-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+skeptic-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+skeptic-devel %{_description}

This package contains library source intended for building other packages which
use the "skeptic" feature of the "%{crate}" crate.

%files       -n %{name}+skeptic-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+skeptic_tests-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+skeptic_tests-devel %{_description}

This package contains library source intended for building other packages which
use the "skeptic_tests" feature of the "%{crate}" crate.

%files       -n %{name}+skeptic_tests-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog