# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}

%global crate regalloc2

Name:           rust-regalloc2
Version:        0.11.1
Release:        %autorelease
Summary:        Backtracking register allocator inspired from IonMonkey

License:        Apache-2.0 WITH LLVM-exception
URL:            https://crates.io/crates/regalloc2
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Backtracking register allocator inspired from IonMonkey.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+checker-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+checker-devel %{_description}

This package contains library source intended for building other packages which
use the "checker" feature of the "%{crate}" crate.

%files       -n %{name}+checker-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+enable-serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+enable-serde-devel %{_description}

This package contains library source intended for building other packages which
use the "enable-serde" feature of the "%{crate}" crate.

%files       -n %{name}+enable-serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+fuzzing-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+fuzzing-devel %{_description}

This package contains library source intended for building other packages which
use the "fuzzing" feature of the "%{crate}" crate.

%files       -n %{name}+fuzzing-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+libfuzzer-sys-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libfuzzer-sys-devel %{_description}

This package contains library source intended for building other packages which
use the "libfuzzer-sys" feature of the "%{crate}" crate.

%files       -n %{name}+libfuzzer-sys-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+trace-log-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+trace-log-devel %{_description}

This package contains library source intended for building other packages which
use the "trace-log" feature of the "%{crate}" crate.

%files       -n %{name}+trace-log-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog