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Abstract

BibleTime is a completely free Bible study program. The program's user interface is built with the Qt framework,
which makes it run on several operating systems including Linux, Windows, FreeBSD and Mac OS X. The software
uses the SWORD programming library to work with over 900 free Bible texts, commentaries, dictionaries and books
in over 50 languages provided by the Crosswire Bible Society and several other repositories.

The BibleTime Handbook is distributed with the BibleTime study program.
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Chapter 1. Introductie
About BibleTime

BibleTime is a Bible study tool with support for different types of texts and languages. Even large amounts
of works modules are easy to install and manage. It is built on the SWORD [http://www.crosswire.org/
sword/] library, which provides the back-end functionality for BibleTime, such as viewing Bible text,
searching etc. SWORD is the flagship product of the Crosswire Bible Society [http://www.crosswire.org].

BibleTime is designed to be used with works encoded in one of the formats supported by the SWORD
project. Complete information on the supported document formats can be found in the  developers section
[http://www.crosswire.org/sword/develop/index.jsp] of the SWORD Project, Crosswire Bible Society.

Beschikbare modules
Over 280 documents in 50 languages are available from the Crosswire Bible Society [http://
www.crosswire.org]. These include:

Bijbels The full Bible text, with optional things like
Strong's Numbers, headings and/or footnotes
in the text. Bibles are available in many
languages, and include not only modern
versions, but also ancient texts like the
Codex Leningradensis ("WLC", Hebrew),
and the Septuagint ("LXX", Greek). This is
the most advanced section in the library of the
SWORD project.

Boeken Books available include "Imitation of Christ",
"Enuma Elish", and "Josephus: The Complete
Works"

Bijbelcommentaren Commentaries available include classics
like John Wesley's "Notes on the Bible",
Matthew Henry's commentary and Luther's
"Commentary on Galatians." With the
Personal commentary you can  record your
own personal notes to sections of the Bible.

Dagelijkse overdenkingen Veel mensen waarderen deze dagelijkse
porties van Gods Woord. Onder de
beschikbare modules bevinden zich Daily
Light on the Daily Path (Dagelijks Licht op
het Dagelijkse Pad) en de Losungen.

Lexicons/Woordenboeken Lexicons available include: Robinson's
Morphological Analysis Codes, and the
International Standard Bible Encyclopaedia.
Dictionaries available include Strong's
Hebrew Bible Dictionary, Strong's Greek
Bible Dictionary, Webster's Revised
Unabridged Dictionary of the English
Language 1913, Nave's Topical Bible.
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Introductie

There are several other repositories that BibleTime will load and use.

Motivatie
Our desire is to serve God, and to do our part to help others grow in their relationship with Him. We have
striven to make this a powerful, quality program, and still make it simple and intuitive to operate. It is our
desire that God be praised, as He is the source of all good things.

Iedere gave, die goed, en elk geschenk, dat volmaakt is, daalt van boven neder, van de
Vader der lichten, bij wie geen verandering is of zweem van ommekeer.

—Jakobus 1:17, NBG51

God zegene u wanneer u dit programma gebruikt.
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Chapter 2. BibleTime opstarten
Hoe u BibleTime opstart

BibleTime opstarten
BibleTime is an executable file that is integrated with the desktop. You can launch BibleTime from the
Start Menu with this icon:

BibleTime can also be launched from a terminal command prompt. To launch BibleTime, open a terminal
window and type:

bibletime

Aanpassing van het opstarten
From a terminal you can use BibleTime to open a random verse in the default bible:

bibletime --open-default-bible "<random>"

To open at a given passage like John 3:16, use:

bibletime --open-default-bible "John 3:16"

You can also use booknames in your current bookname language.

Starting BibleTime for the first time
If you are starting BibleTime for the first time, you will want to configure the following options, available
under the Settings menu bar.

Bookshelf Manager Modifies your Bookshelf. This dialog lets
you modify your Bookshelf, add or delete
works from your system. It will only be
shown if no default Bookshelf can be found.
Please see The Bookshelf Manager section
for further details. If you start off with an
empty Bookshelf, it will be helpful to install
at least one Bible, Commentary, Lexicon
and one Book to get to know BibleTime's
basic features quickly. You will be presented
with a list of works that are available
from the Crosswire Bible Society and other
repositories;

Configure BibleTime dialog Customizes BibleTime.This dialog lets you
adapt BibleTime to your needs. Please see the
detailed description of this dialog.
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Chapter 3. Werking van het programma

Programma overzicht
This is what a typical BibleTime session looks like:

You can easily see the different parts of the application. The top left window is used to open installed
works in the Bookshelf tab, and with the Bookmarks tab you can manage your bookmarks. The little "Mag"
window below the Bookshelf is used to display extra information that is embedded in documents. When
you move your mouse over a footnote marker, for example, then the Mag will display the actual content
of the footnote. The toolbar gives you quick access to important functions, and the Desk on the right side
is where you do your real work.

Laten we nu doorgaan en één voor één de verschillende onderdelen van de toepassing bekijken.

Onderdelen van het BibleTime
toepassingsvenster

De Boekenplank

De Boekenplank laat alle geïnstalleerde modules zien, gesorteerd per categorie en taal. Het heeft ook een
categorie genaamd "Bladwijzers". Dit is de plaats waar u uw eigen bladwijzers kunt opslaan en openen.
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Werking van het programma

Opening works

To open a work from the bookshelf for reading, simply double-click with the left mouse button on
the desired category (Bibles, Commentaries, Lexicons, Books, Devotionals or Glossaries) to display its
contents. Then just double-click on one of the works to open it for reading. A read window will appear
in the Desk area.

If you are reading a certain work, and want to open another work at the passage you are reading, you can
use a shortcut. Simply click with the left mouse button on the verse/passage reference (pointer changes
to hand) and drag it to the Bookshelf. Drop it on the work you want to open, and it will be opened for
reading at the specified location. You can also drag a verse reference into an existing read window, then
it will jump to the specified location.

Additionele informatie over modules

If you click with the right mouse button on the symbol of a work, you will see a menu with additional entries
that are relevant for this work. "About this work" opens a window with lots of interesting information
about the selected work. "Unlock this work" opens a small dialog for encrypted documents, where you
can enter the unlock key to access the work. For additional information on locked works, please see the
Locked Modules [http://www.crosswire.org/sword/modules/aboutlocked.jsp] page on the Crosswire Bible
Society web site.

Zoeken in modules

You can search in a work by clicking with the right mouse button on its symbol and selecting "Search in
work(s)". By pressing Shift and clicking on other works you can select more than one. Then follow the
same procedure to open the search dialog. You will be searching in all of these documents. A complete
description of the operation of the search features can be found on the Searching in Works section.

Werken met bladwijzers

Tip

Drag & Drop Werkt Hier
Click with the right mouse button on the bookmark category of the bookshelf and select "Create new folder"
to create a new bookmark subfolder. You can use normal drag & drop functions to drag verse references
from read windows or search results to the bookmark folder, and to rearrange bookmarks between folders.

You can also import bookmarks from other people or export bookmarks to share them. To do this, open the
context menu of the bookmark folder as described above, and select "Export bookmarks". This will bring
up a dialog box for you to save the bookmark collection. You can import bookmarks in a similar way.

You can also click with the right on folders and bookmarks to change their names and descriptions.

Het Vergrootglas
Dit kleine venster in de linkeronderhoek van het BibleTime venster is volledig passief. Telkens wanneer
uw muisaanwijzer over een stukje tekst met extra informatie gaat (bijv. Strong-nummers), dan wordt deze
extra informatie weergegeven in het Vergrootglas en niet in de tekst zelf. Probeer het maar eens uit.

Het Bureau
The Desk is where the real work with BibleTime takes place. Here you can open works from the Bookshelf,
read them, search in them, and even save your annotations in the personal commentary module (see below).
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Werking van het programma

Modules lezen

Zoals we al gezien hebben, kunt u de te lezen modules simpelweg openen door te klikken op hun symbool
in de Boekenplank. Een leesvenster zal worden geopend in het Bureau gebied. Ieder leesvenster heeft
een werkbalk. Hier kunt u gereedschappen vinden om te navigeren in de module waarin dit leesvenster is
verbonden, alsmede history knoppen zoals u die kent vanuit uw internet browser.

Auto Scrolling

The currently active window can be auto scrolled up or down. Start scrolling by press Shift+Down. You
can increase the scrolling speed by pressing Shift+Down multiple times. To pause scrolling press Space.
To start scrolling again at the previous speed press Space again. To slow down scrolling or scroll the other
direction press Shift+Up one or more times. Pressing any other key or changing the active window will
stop the scrolling.

Plaatsing van leesvensters

Of course, you can open multiple works at the same time. There are several possibilities for arranging the
read windows on the desk. Please have a look at the entry Window in the main menu. There you can see
that you can either control the placement of the read windows completely yourself, or have BibleTime
handle the placement automatically. To achieve this, you have to select one of the automatic placement
modes available at Window → Arrangement mode. Just try it out, it's simple and works.

Uw eigen bijbelcommentaar bewerken

To be able to store your own comments about parts of the Bible, you have install a certain work from
the library of the Crosswire Bible Society [http://www.crosswire.org]. This work is called "Personal
commentary".

Open the personal commentary by clicking on its symbol in the Bookshelf with a left mouse button. You
can edit this commentary by just clicking on any verse. A dialog opens which allows you to add or edit
text for that verse.

Tip

If Edit this work is deactivated, please check if you have write permission for the files of the
personal commentary.

Tip

Drag & drop works here. Drop a verse reference and the text of the verse will be inserted.

Zoeken in modules

Tekst zoeken in een geopend leesvenster

You can look for a word or phrase in the open read window (e.g. the chapter of a bible that you're reading)
just like you are used to from other programs. This function can be reached either by clicking with the
right mouse button and selecting Find..., or by using the shortcut CtrlF. Read on to learn how you can
search in entire works.
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Werking van het programma

De zoekdialoog benaderen

You can search in a work by clicking with the right mouse button on its symbol in the Bookshelf and
selecting Search in work(s). By holding Shift or Ctrl and clicking on other work's names you can select
more than one. Then follow the same procedure to open the search dialog. You will be searching in all
of these works at the same time.

You can also access the search dialog by clicking on Search from the main menu, and selecting the
appropriate entry.

Een derde mogelijkheid om zoekopdrachten te starten is door op het zoeksymbool in een geopend
leesvenster te klikken.

Configuratie van de zoekopdracht

Modules selecteren

At the top of the options tab you will find Choose(works). If you would like to search in multiple works,
click on this button and you will be offered a menu where you can select the works you want to search in.
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Werking van het programma

Zoekbereiken gebruiken

You can narrow the scope of your search to certain parts of the Bible by selecting one of the predefined
scopes from the list in Search scope. You can define your own search ranges by clicking the Setup ranges
button.

Introductie op de syntaxis van een eenvoudige zoekopdracht

Enter the search phrase separated by spaces. By default the search function will return results that match
all the words. If you want to find any of the words entered, select the Some words button. If you want
to perform a more complex search, select the Free button. You can see examples of searches by clicking
on full syntax.

You can use wildcards: '*' matches any number of characters, while '?' will match any single character.
The use of parenthesis allows you to group your search terms, e.g. '(Jesus OR spirit) AND God'.

To search text other than the main text, enter the text type followed by ':', and then the search term. Refer
to the table below for examples.

Available text types:

Table 3.1. Search Types

Voorvoegsel Betekenis Example

Koptekst: doorzoekt kopteksten heading:Jesus

voetnoot: doorzoekt voetnoten footnote:Moses

strong: doorzoekt Strong-nummering strong:G535

morph: doorzoekt morfologische codes morph:N-GSM

Tip

You can right click on an installed work and select About to find which of the above search criteria
may work for you. Not all works have the built in features for performing this type of search.

BibleTime uses the Lucene search engine to perform your searches. It has many advanced features, and
you can read more about it here:  http://lucene.apache.org/java/docs/index.html [http://lucene.apache.org/
java/docs/index.html].

Zoekresultaten
Here you can see how many instances of the search string were found, sorted by works. Clicking on a
work with the right mouse button allows you to copy, save, or print all verses that were found in a certain
work at once. This also works when you click on one or more of the references to copy, save or print them.
Clicking on a particular reference opens that verse up in context in the preview window below.

Tip

Sleep een bijbelverwijzing en laat die los op een symbool van een module op de Boekenplank
om de module op dat vers in een nieuw leesvenster te openen.

Tip

Sleep een bijbelverwijzing en laat die vallen op een geopend leesvenster en die zal verspringen
naar dat vers.
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Werking van het programma

Tip

Selecteer bijbelverwijzingen en sleep ze naar de Boekenplank om bladwijzers te maken.

Analyse van zoekresultaten

Click on Search analysis to open the search analysis display. This gives a simple graphic analysis of the
number of instances the search string was found in each book of the Bible, and you can also save the
analysis.

De Boekenplank Manager
The Bookshelf Manager is a tool to manage your Bookshelf. You can install new works to your Bookshelf,
and update or remove existing works from your Bookshelf. Access it by clicking Settings → Bookshelf
Manager in the main menu.

Install works
With this facility, you can connect to a repository of works (called "library"), and transfer one or more
works to your local Bookshelf. These libraries may be local (e.g. a SWORD CD), or remote (e.g.
Crosswire's online repository of SWORD modules, or another site offering SWORD modules). BibleTime
will automatically maintain a list of remote libraries and the works available from them.

To begin the installation process, select one or more libraries that you want to install works from. Then
click on the Next button. Then select one or more languages and click the Next button. You will see a list
of categories. Double-click on a category to see works for that category. Select one or more works and
then click on the Install Works. After the works are installed, click on the Finish.

Update works
If there are any works that can be updated, they will be shown. Select one or more work and click the
Update Works. After the works are updated, click on the Finish.
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Werking van het programma

Remove works
This facility allows you to delete one or more of the works from your Bookshelf too free up disk space.
Simply choose the works` and click on the Remove works button.

Exporteren en Printen
In many places, you can open a context menu by clicking with the right mouse button. Depending on
context, it will allow you to Select, Copy (to clipboard), Save or Print text. This works for example in the
read windows, when you click on the normal text or the verse reference, or in the search result page when
you click on a work or one or more verse references. It is pretty straightforward, so just try it out.

Afdrukken vanuit BibleTime is redelijk elementair en is bedoelt als een hulpfunctie. Als u een document
of presentatie samenstelt die tekst bevat uit BibleTime modules, dan raden we u aan om een programma
voor presentaties of tekstbewerkingen te gebruiken om uw document op te maken en niet om direct vanuit
BibleTime af te drukken.
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Chapter 4. Bezig met het configureren
van BibleTime

In deze sectie vindt u een overzicht, hoe BibleTime te configureren. Dit kan gevonden worden onder
instellingen in het hoofdmenu.

Configureer BibleTime Dialoog
De BibleTime gebruikers-interface kan op vele manieren worden aangepast aan uw behoeften. Het
configuratie dialoog vindt u door te selecteren: Instellingen Configureer BibleTime.

Beeld

Het gedrag bij het opstarten kan aangepast worden aan de gebruiker. Maak een keuze uit de volgende
opties:

• Toon opstartlogo

Display templates define the rendering of text (colors, size etc.). Various built-in templates are available.
If you select one, you will see a preview on the right pane.

Bureau

Many features provided by the SWORD backend can now be customized in BibleTime. These features
are documented right in the dialog. You also have the possibility to specify standard works that should be
used when no specific work is specified in a reference. An example: The standard Bible is used to display
the content of cross references in the Bible. When you hover over them, the Mag will show the content
of the verses referred to, according to the standard Bible you specified. With the use of text filters, you
can control the appearance of the text.

Talen

Hier kunt u specificeren welke talen gebruikt moeten worden voor de bijbelboeknamen. Stel dit op uw
moedertaal als deze beschikbaar is en u voelt zich helemaal thuis.

Standaard maakt BibleTime gebruik van het systeem lettertype. U kunt dit lettertype zo nodig
overschrijven. Sommige talen vereisen speciale lettertypen om correct te worden weergegeven, in dit
dialoogvenster kunt u een aangepast lettertype aangeven voor elke taal.
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Bezig met het configureren
van BibleTime

De Opties dialoog - Lettertypen

BibleTime kan nu alle ondersteunde lettertypen gebruiken. Zolang de modules waarin u geïnteresseerd
bent correct worden weergegeven, hoeft hier niets te worden gedaan. Als een module alleen wordt
weergegeven als een reeks vraagtekens (??????) of lege vakjes, weet u dat het standaardlettertype niet de
tekens bevat die in deze module zijn gebruikt.

To correct this, choose this work's language from the drop down menu. Select the use custom font
checkbox. Now select a font. For example, a font that supports many languages is Code2000. If no installed
font can display the work you are interested in, try installing the localization package for that language.

Lettertypen installeren

Gedetailleerde lettertype installatie instructies vallen buiten het bereik van deze handleiding. Meer
informatie zou u kunnen vinden in de  Unicode HOWTO [http://www.linux.org/docs/ldp/howto/Unicode-
HOWTO-2.html].

Lettertypen kunnen worden geïnstalleerd uit een aantal bronnen:

• Uw *nix distributie.

• De lokalisatiepakketten (localization packages) in uw distributie.

• Een bestaande Microsoft Windows® installatie op dezelfde computer.

• Een verzameling lettertypen, zoals beschikbaar is van Adobe of Bitstream.
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Bezig met het configureren
van BibleTime

• Online verzamelingen van lettertypen.

Unicode fonts support more characters than other fonts, and some of these fonts are available at no charge.
None of available fonts includes all characters defined in the Unicode standard, so you may want to use
different fonts for different languages.

Table 4.1. Unicode lettertypen

Code2000 [http://code2000.net/CODE2000.ZIP] Misschien het beste gratis Unicode lettertype, welke
een groot aantal karakters ondersteunt.

SIL unicode fonts [http://scripts.sil.org/cms/scripts/
page.php?site_id=nrsi&cat_id=FontDownloads]

Excellente Unicode lettertypen van het Summer
Institute of Linguistics.

FreeFont [http://www.nongnu.org/freefont/] Een nieuw gratis Unicode lettertype initiatief.

Crosswire's lettertype directory [ftp://
ftp.crosswire.org/pub/sword/iso/latest/FONTS/]

Diverse lettertypen beschikbaar van de Crosswire
Bible Society FTP site.

Bitstream CyberBit [http://aol-4.vo.llnwd.net/pub/
communicator/extras/fonts/windows/]

Dekt bijna het gehele bereik van Unicode, maar kan
BibleTime vertragen door zijn omvang.

Clearlyu Is inbegrepen in sommige distributies. Bevat
Europese, Griekse, Hebreeuwse en Thaise
karakters.

Caslon, Monospace, Cupola, Caliban [http://
fontforge.sourceforge.net/sfds/]

Gedeeltelijk bereik van de Unicode standaard, zie
voor meer informatie op de bijbehorende website.

There are good Unicode font lists on the net, as the one by Christoph Singer ( Multilingual Unicode
TrueType Fonts in the Internet [http://www.slovo.info/unifonts.htm]), or the one by Alan Wood (
Unicode character ranges and the Unicode fonts that support them [http://www.alanwood.net/unicode/
fontsbyrange.html]).

Shortcuts

Shortcuts (previously known as HotKeys) are special key commands that can be used in the place of the
menu items and icons. A number of BibleTime's commands have predefined Shortcuts (see the Shortcuts
section for a complete listing). Most of BibleTime's commands can be assigned Shortcuts. This is very
helpful to quickly access the functions that you need the most.
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Bezig met het configureren
van BibleTime

In the preceding example, F2, Bible Study HowTo has a secondary shortcut defined, CTRL+2.
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Chapter 5. Verwijzing
Hoofdmenu verwijzing

In this section you can find detailed descriptions of all entries in the main menu of BibleTime. They are
ordered in just the way they appear in BibleTime, with all the sub-items listed under the major menu item
they belong to. You can also see the shortcut of each item;a complete listing of all shortcuts can be found
in the shortcuts section.

File

File 

→

 Open work

Open work. This will give you a menu that
will allow you to open installed books.

File 

→

 Quit (Ctrl+Q)

Closes BibleTime. BibleTime will ask you if
you want to write unsaved changes to disk.

View

View 

→

 Fullscreen mode (F5)

Toggles full screen display. Toggle this
setting to maximize the BibleTime window.

View 

→

 Show Bookshelf

Schakelt de weergave van de Boekenplank
in/uit. Schakel deze instelling in/uit om de
Boekenplank in het linkerpaneel wel/niet
weer te geven. Dit kan handig zijn als u meer
ruimte nodig heeft voor het vergrootglas.

View 

→

 Show Bookmarks

Toggles display of the Bookmarks. Toggle
this setting to turn the Bookmarks on the left
pane on or off. This can be handy if you need
more space for the Mag.

View 

→

 Show Mag

Schakelt de weergave van het Vergrootglas
in/uit. Schakel deze instelling in/uit om het
Vergrootglas in het linkerpaneel aan/uit te
zetten.

View 

→

 Show parallel text headers

Toggles viewing of additional works Toggle
this setting to allow you to view additional
works in parallel to your current open books.

View → Toolbars → Show main (F6) Toggles Main Toolbar display. Toggle this
setting to turn the main toolbar on or off.

View → Toolbars → Show navigation Toggles Navigation in works. Toggle this
setting to add or remove the navigation
combo box in works. This can be handy to
view the full toolbar in the open works
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Verwijzing

View → Toolbars → Show works Toggles Toolbars in works. Toggle this
setting to add or remove the works icons in
the open works.

View → Toolbars → Show tools Toggles tools in works. Toggle this setting
to add or remove the tools icons in the open
works.

View → Toolbars → Show format Toggles format. Toggle this setting when
editing HTML in Personal Commentaries. It
will add or remove the formatting toolbar.

View → Toolbars → Show toolbars in text windows Toggles toolbars in works. Toggle this setting
to add or remove the complete toolbar in open
works.

Search

Search 

→

 Search in standard bible (Ctrl+Alt+F)

Opens the Search Dialog to search in the
standard Bible only. More works can be
added in the Search Dialog. A more detailed
search description can be found in the
Searching in works section.

Search 

→

 Search in open work(s) (Ctrl+O)

Opens the Search Dialog to search in all open
works. Works can be added or removed in
the Search Dialog. A more detailed search
description can be found in the Searching in
works section.

Window

Window 

→

 Close window (Ctrl+W)

Closes active window.

Window 

→

 Close all (Ctrl+Alt+W)

Sluit alle geopende vensters

Window 

→

 Cascade (Ctrl+J)

Rangschikt alle geopende vensters
trapsgewijs (achter elkaar)

Window 

→

 Tile (Ctrl+I)

Tiles all open windows.

Window 

→

 Tile vertically (Ctrl+G)

Automatically tiles all open windows
vertically.

Window 

→

 Tile horizontally (Ctrl+H)

Automatically tiles all open windows
horizontally.
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Window → Arrangement mode Controls the basic window arrangement
behaviour. In the opening context menu, you
can either specify that you want to take care
of the window arrangement yourself (Manual
mode), Tabbed, Auto-tile vertically, Auto-tile
horizontally, Auto-tile or Auto-cascade. Just
try them out!

Window → Save session Directly saves the current session. This will
open a context menu where you can select
an existing session to save to. It will be
overwritten with your current session. See the
next item on how to save to a new session.

Window → Save as new session (Ctrl+Alt+S) Saves the current session under a new name.
This will ask for a new name to save the
session to.

Window → Load session Loads an existing session. This will open
a context menu where you can select an
existing session to load.

Window → Delete session Deletes an existing session. This will open
a context menu where you can select an
existing session that should be deleted.

Settings

Settings 

→

 Configure BibleTime

Opens BibleTime's main configuration
dialog. You can configure all kinds of nice
settings there to adapt BibleTime to your
needs. Please see the Configuring BibleTime
section for details.

Settings 

→

 Bookshelf Manager (F4)

Opens a dialog where you can change your
SWORD configuration and manage your
bookshelf. Please see the Bookshelf Manager
section for details.

Help

Help 

→

 Handbook (F1)

Opens BibleTime's user guide You are
reading it now.

Help 

→

 Bible Study HowTo (F2)

Opens a guide on how to study the Bible It
is the hope of the BibleTime team that this
HowTo will provoke the readers to study the
scriptures to see what they say. This particular
study guide has been chosen as it takes care
not to advocate any particular denominational
doctrine. We expect you to read and study the
scriptures to understand what they say. If you
start with the attitude that you want to have
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the Lord sow his word in your heart He will
not disappoint you.

Help 

→

 Tip of the Day (F3)

Opens a helpful tip The Tip of the Day
provides a useful tip that will assist in the use
of BibleTime.

Help → About Opens a window about BibleTime
project information contains information
about BibleTime software version, project
contributors, SWORD software version, Qt
software version and the license agreement.

Works reference
In this section you can find descriptions of the icons associated with open works.

Scrolls forward through history.

Scrolls back through history.

Select an installed bible.

Select an additional bible.

Search in selected works.

Display configuration.

Select an installed commentary.

Select additional commentary.

Synchronize displayed entry with active
Bible window.

Select a book.

18



Verwijzing

Select an installed glossary or devotional.

Select an additional glossary or devotional.

Shortcuts index
This is an index of all shortcuts and their corresponding description in the handbook. The shortcuts are
sorted (roughly) alphabetical. If you want to directly find out which shortcuts a certain menu item has,
you can either look at the entry itself in BibleTime (as it always shows the shortcut), or you can look it
in the Main Menu reference.

Shortcut Beschrijving

Alt+Left Gaat terug in de history van leesvensters

Alt+Right Gaat vooruit in de history van leesvensters

Ctrl+Alt+F Search → Search in default bible  equivalent; opens
the search dialog to search in the default bible.

Ctrl+Alt+G Window → Arrangement mode → Auto-tile
vertically equivalent; toggle automatic window
tiling.

Ctrl+Alt+H Window → Arrangement mode → Auto-tile
horizontally equivalent; toggle automatic window
tiling.

Ctrl+Alt+I Window → Arrangement mode → Auto-tile
equivalent; toggle automatic window tiling.

Ctrl+Alt+J Window → Arrangement mode → Auto-cascade
equivalent; toggle automatic window cascading.

Ctrl+Alt+M Window → Arrangement mode → Manual mode
equivalent; toggle manual window placement.

Ctrl+Alt+T Window → Arrangement mode → Tabbed
equivalent; organizes windows with tabs across the
top.

Ctrl+Alt+S Window → Save as new session  equivalent; saves
current layout as new session.

Ctrl+Alt+W Window → Close all  equivalent; closes all open
windows.

Ctrl+A Selecteer alles. Dit selecteert alle tekst in de
leesvensters.

Ctrl+C Kopieëren. Dit kopieert de geselecteerde tekst naar
het klembord.

Ctrl+F Zoeken. Dit laat u zoeken binnen de tekst van een
leesvenster.

Ctrl+G Window → Tile vertically  equivalent.

Ctrl+H Window → Tile horizontally  equivalent.
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Shortcut Beschrijving

Ctrl+I Window → Tile  windows equivalent.

Ctrl+J Window → Cascade  windows equivalent.

Ctrl+L Change location. Changes focus to the toolbar field
for the selected work.

Ctrl+N Search with works of this window.

Ctrl+O Search → Search in open work(s)  equivalent; opens
the search dialog to search in all currently opened
works.

Ctrl+Q File → Quit  equivalent; closes BibleTime.

Ctrl+W Sluit het huidige venster.

F1 Help → Handbook equivalent; opens the handbook.

F2 Help → BibleStudy HowTo equivalent; opens the
BibleStudy HowTo.

F3 Help → Tip of the Day Opens a helpful tip to use
BibleTime.

F4 Settings → Bookshelf Manager  equivalent; opens
the Bookshelf Manager.

F8 View → Show Bookshelf  equivalent; toggles
display of the Bookshelf.

F9 View → Show mag  equivalent; toggles display of
the mag(nifying glass).

Shift+Down View → Auto scroll down

Shift+Up View → Auto scroll up

Space View → Auto scroll pause
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