%global pkgvers 0
%global scdate0 20231027
%global schash0 52639a5ab47cbb970aaccf22c44534f8723b0d9d
%global branch0 master
%global source0 https://github.com/fmorenopino/HeterogeneousHMM.git

%global sshort0 %{expand:%%{lua:print(('%{schash0}'):sub(1,8))}}

Name:           pyhhmm
Version:        2.0.0
Release:        %{scdate0}.%{pkgvers}.git%{sshort0}%{?dist}
Summary:        Heterogeneous Hidden Markov Models
License:        Apache
BuildArch:      noarch

URL:            https://github.com/fmorenopino/HeterogeneousHMM

BuildRequires:  git make python3-devel python3-setuptools
Requires:       %{name}-python3

%description
Implementations of the Hidden Markov Model with just
some basic Python dependencies.

%package        python3
Summary:        Python files for %{name}
Provides:       %{name}

%description    python3
Implementations of the Hidden Markov Model with just
some basic Python dependencies.


%prep
%setup -T -c -n %{name}
git clone --depth 1 -n -b %{branch0} %{source0} .
git fetch --depth 1 origin %{schash0}
git reset --hard %{schash0}
git log --format=fuller


%build
rm -rf req*.txt
sed -i "s|'seaborn'||" setup.py
%py3_build

%install
rm -rf %{buildroot}
%py3_install


%files python3
%license LICENSE
%doc README.rst
%doc examples
%doc docs
%{python3_sitelib}/*


%changelog
* Wed Dec 04 2019 Balint Cristian <cristian.balint@gmail.com>
- github build releases