%global pkgvers 0
%global scdate0 20231229
%global schash0 c335e7414e1f1260ce6e42c81456f5965d7808b6
%global branch0 main
%global source0 https://github.com/pyhopper/pyhopper.git

%global sshort0 %{expand:%%{lua:print(('%{schash0}'):sub(1,8))}}

Name:           pyhopper
Version:        1.0.0
Release:        %{scdate0}.%{pkgvers}.git%{sshort0}%{?dist}
Summary:        Optimizing high-dimensional hyperparameters
License:        Apache
BuildArch:      noarch

URL:            https://pyhopper.io

BuildRequires:  git python3-devel python3-setuptools

%description
PyHopper is a hyperparameter optimizer, made specifically for
high-dimensional problems arising in machine learning research
and businesses.


%prep
%setup -T -c -n %{name}
git clone --depth 1 -n -b %{branch0} %{source0} .
git fetch --depth 1 origin %{schash0}
git reset --hard %{schash0}
git log --format=fuller


%build
%py3_build


%install
%py3_install


%files
%license LICENSE
%doc README.md
%{python3_sitelib}/%{name}/
%{python3_sitelib}/%{name}-*.egg-info/


%changelog
* Fri Mar 29 2019 Balint Cristian <cristian.balint@gmail.com>
- github upstream releases