## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}

%global crate libphosh

Name:           rust-libphosh
Version:        0.0.6
Release:        %autorelease
Summary:        Rust bindings for libphosh

License:        MIT
URL:            https://crates.io/crates/libphosh
Source:         %{crates_source}

ExcludeArch:    %{ix86}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Rust bindings for libphosh.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v2_10-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v2_10-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v2_10" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v2_10-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v2_12-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v2_12-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v2_12" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v2_12-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v2_18-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v2_18-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v2_18" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v2_18-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v2_20-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v2_20-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v2_20" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v2_20-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v2_4-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v2_4-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v2_4" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v2_4-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v2_6-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v2_6-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v2_6" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v2_6-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v3-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v3-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v3" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v3-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v3_12-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v3_12-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v3_12" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v3_12-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v3_14-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v3_14-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v3_14" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v3_14-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v3_20-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v3_20-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v3_20" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v3_20-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v3_4-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v3_4-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v3_4" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v3_4-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gtk_v3_8-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gtk_v3_8-devel %{_description}

This package contains library source intended for building other packages which
use the "gtk_v3_8" feature of the "%{crate}" crate.

%files       -n %{name}+gtk_v3_8-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+v3_12-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v3_12-devel %{_description}

This package contains library source intended for building other packages which
use the "v3_12" feature of the "%{crate}" crate.

%files       -n %{name}+v3_12-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+v3_14-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v3_14-devel %{_description}

This package contains library source intended for building other packages which
use the "v3_14" feature of the "%{crate}" crate.

%files       -n %{name}+v3_14-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Sun Feb 09 2025 Sam Day <me@samcday.com> - 0.0.6-1
- Upgrade to 0.0.6

* Sun Jan 19 2025 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_42_Mass_Rebuild

* Wed Jan 15 2025 Sam Day <me@samcday.com> - 0.0.5-1
- Initial import (fedora#2334842)
## END: Generated by rpmautospec