## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

%global srcname crossword
# The GitHub repo doesn't have tags, this is the commit corresponding to the
# 0.1.2 release in PyPI
%global commit 57078ad5ab5e1ef1bfaa909ca392e1c76e99be1f

Name:           python-%{srcname}
Version:        0.1.2
Release:        %autorelease
Summary:        Python library for handling crossword puzzles

License:        MIT
URL:            https://github.com/svisser/crossword
# The PyPI tarball doesn't include tests, so use GitHub instead
Source:         %{url}/archive/%{commit}/%{srcname}-%{commit}.tar.gz

BuildArch:      noarch
BuildRequires:  python3-devel
BuildRequires:  sed

%global _description %{expand:
Python library for handling crossword puzzles. This library provides a
canonical data structure that can be used to represent crosswords in your
application. It provides a Pythonic way to perform common operations on the
grid, the words and the clues of the puzzle.}

%description %_description

%package -n     python3-%{srcname}
Summary:        %{summary}

%description -n python3-%{srcname} %_description

%prep
%autosetup -p1 -n %{srcname}-%{commit}

# Do not pull puzpy from git and relax version pinning
sed -i test-requirements.txt -e 's/-e.*puzpy_master/puzpy/' -e 's/==.*$//g'

%generate_buildrequires
%pyproject_buildrequires -t

%build
%pyproject_wheel

%install
%pyproject_install
%pyproject_save_files %{srcname}

%check
%tox

%files -n python3-%{srcname} -f %{pyproject_files}
%license LICENSE
%doc CHANGELOG.rst README.rst

%changelog
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> 0.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Thu Nov 17 2022 Davide Cavalca <dcavalca@fedoraproject.org> 0.1.2-1
- Initial import; Fixes: RHBZ#2138486