## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

Name:           pyp2spec
Version:        0.11.1
Release:        %autorelease
Summary:        Generate Fedora RPM spec files for Python projects

# Code is MIT, templates and files generated by the tool MIT-0
License:        MIT AND MIT-0
URL:            https://github.com/befeleme/pyp2spec
Source0:        %{pypi_source pyp2spec}

BuildArch:      noarch
BuildRequires:  python3-devel


%description
pyp2spec is a tech preview. It is a tool generating Fedora RPM spec files
for Python distributions. It utilizes the benefits of pyproject-rpm-macros.


%prep
%autosetup -p1 -n pyp2spec-%{version}


%generate_buildrequires
%pyproject_buildrequires -t


%build
%pyproject_wheel


%install
%pyproject_install
%pyproject_save_files pyp2spec -l


%check
%tox


%files -f %{pyproject_files}
%doc README.md
%{_bindir}/pyp2spec
%{_bindir}/conf2spec
%{_bindir}/pyp2conf


%changelog
## START: Generated by rpmautospec
* Thu Nov 21 2024 Karolina Surma <ksurma@redhat.com> - 0.11.1-1
- Update to 0.11.1

* Tue Oct 22 2024 Karolina Surma <ksurma@redhat.com> - 0.11.0-2
- Assert a license is always detected with the files

* Tue Oct 22 2024 Karolina Surma <ksurma@redhat.com> - 0.11.0-1
- Update to 0.11.0

* Thu Oct 10 2024 Karolina Surma <ksurma@redhat.com> - 0.10.0-1
- Update to 0.10.0

* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Sun Jun 09 2024 Python Maint <python-maint@redhat.com> - 0.9.0-2
- Rebuilt for Python 3.13

* Thu Apr 11 2024 Karolina Surma <ksurma@redhat.com> - 0.9.0-1
- Update to 0.9.0

* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Wed Oct 11 2023 Karolina Surma <ksurma@redhat.com> - 0.8.0-1
- Update to 0.8.0

* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Thu Jun 29 2023 Python Maint <python-maint@redhat.com> - 0.7.0-3
- Rebuilt for Python 3.12

* Thu May 04 2023 Karolina Surma <ksurma@redhat.com> - 0.7.0-2
- Change the License tag to SPDX expression

* Thu May 04 2023 Karolina Surma <ksurma@redhat.com> - 0.7.0-1
- Update to 0.7.0

* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Mon Aug 01 2022 Karolina Surma <ksurma@redhat.com> - 0.6.1-2
- Include the source tarball

* Mon Aug 01 2022 Karolina Surma <ksurma@redhat.com> - 0.6.1-1
- Update to 0.6.1

* Mon Aug 01 2022 Karolina Surma <ksurma@redhat.com> - 0.6.0-1
- Update to 0.6.0

* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Tue Jun 21 2022 Karolina Surma <ksurma@redhat.com> - 0.5.0-1
- Initial import
## END: Generated by rpmautospec