# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate jsonwebkey

Name:           rust-jsonwebkey
Version:        0.3.5
Release:        %autorelease
Summary:        JSON Web Key (JWK) (de)serialization, generation, and conversion

License:        MIT
URL:            https://crates.io/crates/jsonwebkey
Source:         %{crates_source}

# Manually created patch for downstream crate metadata changes
# Changes done for Fedora:
# - Require 'yasna' version "0.5"
# - Dependency jsonwebtoken removed as it's only
#   required by hidden feature 'jwt-convert'
# - Dependencies p256 and rand were removed as they are only 
#   required by hidden feature 'generate'
# - "dep:" was added to all dependencies in [features] table as
#   it seems this overcomes an issue with rust2rpm
Patch:          jsonwebkey-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
JSON Web Key (JWK) (de)serialization, generation, and conversion.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+pkcs-convert-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+pkcs-convert-devel %{_description}

This package contains library source intended for building other packages which
use the "pkcs-convert" feature of the "%{crate}" crate.

%files       -n %{name}+pkcs-convert-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog