## START: Set by rpmautospec
## (rpmautospec version 0.5.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 25
# * tests can only be run in-tree
%bcond_with check
%global debug_package %{nil}

%global crate futures-task

Name:           rust-futures-task
Version:        0.3.30
Release:        %autorelease
Summary:        Tools for working with tasks

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/futures-task
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Tools for working with tasks.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+alloc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+alloc-devel %{_description}

This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.

%files       -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cfg-target-has-atomic-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cfg-target-has-atomic-devel %{_description}

This package contains library source intended for building other packages which
use the "cfg-target-has-atomic" feature of the "%{crate}" crate.

%files       -n %{name}+cfg-target-has-atomic-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.30-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Wed Dec 27 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.30-1
- Update to version 0.3.30; Fixes RHBZ#2246395

* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.28-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Sun Apr 02 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.28-1
- Update to version 0.3.28; Fixes RHBZ#2183274

* Wed Mar 15 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.27-1
- Update to version 0.3.27; Fixes RHBZ#2177422

* Fri Feb 03 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.26-1
- Update to version 0.3.26; Fixes RHBZ#2165665

* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.25-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Tue Dec 13 2022 Fabio Valentini <decathorpe@gmail.com> - 0.3.25-1
- Update to version 0.3.25; Fixes RHBZ#2136360

* Tue Sep 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.3.24-1
- Update to version 0.3.24; Fixes RHBZ#2122253

* Tue Aug 16 2022 Fabio Valentini <decathorpe@gmail.com> - 0.3.23-1
- Update to version 0.3.23; Fixes RHBZ#2118128

* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.21-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Mon Feb 07 2022 Fabio Valentini <decathorpe@gmail.com> - 0.3.21-1
- Update to version 0.3.21; Fixes RHBZ#2051091

* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.19-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Mon Dec 20 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.19-1
- Update to version 0.3.19; Fixes RHBZ#2033917

* Wed Nov 24 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.18-1
- Update to version 0.3.18; Fixes RHBZ#2025779

* Mon Aug 30 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.17-1
- Update to version 0.3.17; Fixes RHBZ#1999068

* Wed Jul 28 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.16-1
- Update to version 0.3.16; Fixes RHBZ#1985533

* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.15-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Thu May 27 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.15-1
- Update to version 0.3.15.

* Thu Apr 22 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.14-1
- Update to version 0.3.14.

* Tue Feb 23 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.13-1
- Update to version 0.3.13.

* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.12-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Fri Jan 15 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.12-1
- Update to version 0.3.12.

* Wed Jan 13 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.10-1
- Update to version 0.3.10.

* Fri Jan 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.3.9-1
- Update to version 0.3.9.

* Mon Nov 09 2020 Fabio Valentini <decathorpe@gmail.com> - 0.3.8-1
- Update to version 0.3.8.
- Fixes RHBZ#1896111

* Mon Oct 26 2020 Fabio Valentini <decathorpe@gmail.com> - 0.3.7-1
- Update to version 0.3.7.

* Wed Oct 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.3.6-1
- Update to version 0.3.6.

* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Sat May 09 2020 Josh Stone <jistone@redhat.com> - 0.3.5-1
- Update to 0.3.5

* Mon Feb 10 2020 Josh Stone <jistone@redhat.com> - 0.3.4-1
- Update to 0.3.4

* Thu Feb 06 2020 Josh Stone <jistone@redhat.com> - 0.3.3-1
- Update to 0.3.3

* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Fri Dec 13 20:52:40 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.1-1
- Initial package

## END: Generated by rpmautospec