## START: Set by rpmautospec
## (rpmautospec version 0.2.5)
%define autorelease(e:s:pb:) %{?-p:0.}%{lua:
    release_number = 3;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{?dist}
## END: Set by rpmautospec

# Generated by rust2rpm 20
%bcond_without check

%global crate askalono-cli

Name:           rust-%{crate}
Version:        0.4.4
Release:        %autorelease
Summary:        Tool to detect the contents of license files

# Upstream license specification: Apache-2.0
License:        ASL 2.0
URL:            https://crates.io/crates/askalono-cli
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging

%global _description %{expand:
Tool to detect the contents of license files.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# ASL 2.0 or Boost: rust-ryu 1.0.9
# ASL 2.0 or MIT: rust-autocfg 1.0.1
# ASL 2.0 or MIT: rust-cexpr 0.6.0
# ASL 2.0 or MIT: rust-fnv 1.0.7
# ASL 2.0 or MIT: rust-peeking_take_while 0.1.2
# ASL 2.0 or MIT: rust-rayon 1.5.1
# ASL 2.0 or MIT: rust-rayon-core 1.9.1
# ASL 2.0 or MIT: rust-rustc-hash 1.1.0
# ASL 2.0 or MIT: rust-structopt-derive0.2 0.2.18
# ASL 2.0 or MIT: rust-structopt0.2 0.2.18
# ASL 2.0 or MIT: rust-thread_local 1.1.4
# ASL 2.0: rust-askalono 0.4.4
# ASL 2.0: rust-askalono-cli 0.4.4
# ASL 2.0: rust-clang-sys 1.3.0
# BSD: rust-bindgen 0.59.2
# MIT or ASL 2.0 or zlib: rust-tinyvec_macros 0.1.0
# MIT or ASL 2.0: rust-anyhow 1.0.52
# MIT or ASL 2.0: rust-bitflags 1.3.2
# MIT or ASL 2.0: rust-bstr 0.2.17
# MIT or ASL 2.0: rust-cc 1.0.72
# MIT or ASL 2.0: rust-cfg-if 1.0.0
# MIT or ASL 2.0: rust-crossbeam-channel 0.5.2
# MIT or ASL 2.0: rust-crossbeam-deque 0.8.1
# MIT or ASL 2.0: rust-crossbeam-epoch 0.9.6
# MIT or ASL 2.0: rust-crossbeam-utils 0.8.6
# MIT or ASL 2.0: rust-either 1.6.1
# MIT or ASL 2.0: rust-env_logger 0.9.0
# MIT or ASL 2.0: rust-env_logger0.7 0.7.1
# MIT or ASL 2.0: rust-glob 0.3.0
# MIT or ASL 2.0: rust-heck0.3 0.3.3
# MIT or ASL 2.0: rust-humantime 2.1.0
# MIT or ASL 2.0: rust-humantime1 1.3.0
# MIT or ASL 2.0: rust-itoa 1.0.1
# MIT or ASL 2.0: rust-jobserver 0.1.24
# MIT or ASL 2.0: rust-lazy_static 1.4.0
# MIT or ASL 2.0: rust-lazycell 1.3.0
# MIT or ASL 2.0: rust-libc 0.2.113
# MIT or ASL 2.0: rust-log 0.4.14
# MIT or ASL 2.0: rust-minimal-lexical 0.2.1
# MIT or ASL 2.0: rust-num-traits 0.2.14
# MIT or ASL 2.0: rust-num_cpus 1.13.1
# MIT or ASL 2.0: rust-once_cell 1.9.0
# MIT or ASL 2.0: rust-pkg-config 0.3.24
# MIT or ASL 2.0: rust-proc-macro2 1.0.36
# MIT or ASL 2.0: rust-proc-macro2-0.4 0.4.30
# MIT or ASL 2.0: rust-quick-error1 1.2.3
# MIT or ASL 2.0: rust-quote 1.0.14
# MIT or ASL 2.0: rust-quote0.6 0.6.13
# MIT or ASL 2.0: rust-regex 1.5.4
# MIT or ASL 2.0: rust-regex-syntax 0.6.25
# MIT or ASL 2.0: rust-scopeguard 1.1.0
# MIT or ASL 2.0: rust-serde 1.0.134
# MIT or ASL 2.0: rust-serde_derive 1.0.134
# MIT or ASL 2.0: rust-serde_json 1.0.74
# MIT or ASL 2.0: rust-shlex 1.1.0
# MIT or ASL 2.0: rust-syn 1.0.86
# MIT or ASL 2.0: rust-syn0.15 0.15.44
# MIT or ASL 2.0: rust-unicode-normalization 0.1.19
# MIT or ASL 2.0: rust-unicode-segmentation 1.8.0
# MIT or ASL 2.0: rust-unicode-width 0.1.9
# MIT or ASL 2.0: rust-unicode-xid 0.2.2
# MIT or ASL 2.0: rust-unicode-xid0.1 0.1.0
# MIT or ASL 2.0: rust-vec_map 0.8.2
# MIT or ASL 2.0: rust-version_check 0.9.4
# MIT or ASL 2.0: rust-zstd-safe 4.1.3
# MIT or ASL 2.0: rust-zstd-sys 1.6.2
# MIT: rust-ansi_term 0.12.1
# MIT: rust-atty 0.2.14
# MIT: rust-clap2 2.34.0
# MIT: rust-memoffset 0.6.5
# MIT: rust-nom 7.1.0
# MIT: rust-rmp 0.8.9
# MIT: rust-rmp-serde 0.14.3
# MIT: rust-strsim 0.10.0
# MIT: rust-textwrap0.11 0.11.0
# MIT: rust-which 4.2.2
# MIT: rust-zstd 0.9.2
# Unlicense or MIT: rust-aho-corasick 0.7.18
# Unlicense or MIT: rust-byteorder 1.4.3
# Unlicense or MIT: rust-globset 0.4.8
# Unlicense or MIT: rust-ignore 0.4.18
# Unlicense or MIT: rust-memchr 2.4.1
# Unlicense or MIT: rust-same-file 1.0.6
# Unlicense or MIT: rust-termcolor 1.1.2
# Unlicense or MIT: rust-walkdir 2.3.2
# zlib or ASL 2.0 or MIT: rust-tinyvec 1.5.1
License:        ASL 2.0 and BSD and MIT

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE NOTICE
%doc README.md
%{_bindir}/askalono

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Tue Jan 25 2022 Fabio Valentini <decathorpe@gmail.com> 0.4.4-3
- Rebuild with thread_local 1.1.4 for RUSTSEC-2022-0006

* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.4.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Wed Dec 15 2021 Fabio Valentini <decathorpe@gmail.com> 0.4.4-1
- Update to version 0.4.4; Fixes RHBZ#2025327

* Sat Aug 07 2021 Fabio Valentini <decathorpe@gmail.com> - 0.4.3-5
- Rebuild with crossbeam-deque 0.8.1 / 0.7.4 for CVE-2021-32810

* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Mon Dec 28 13:27:13 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.3-2
- Rebuild

* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.4.3-1
- Update to version 0.4.3.

* Sun Aug 16 15:01:11 GMT 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.2-5
- Rebuild

* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Thu Apr 02 08:21:10 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.2-3
- Fixup license

* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Mon Jan 20 21:52:47 CET 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0.4.2-1
- Update to 0.4.2
- Fix license to include all statically linked libraries

* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Sun Jul 21 10:17:13 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-2
- Regenerate

* Thu Mar 28 12:56:20 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.0-1
- Initial package